Browser Information

  • We officially support Microsoft Internet Explorer 7 and above, Mozilla Firefox 2 and above, Google Chrome 10 and above and Apple Safari 4 and above, though for the best experience, we recommend the latest stable release.
  • We no longer support Internet Explorer 6 or below. If you are using Internet Explorer 6 or below (you can see what version you're using by selecting the "Help" menu and clicking "About") we strongly recommend you upgrade as soon as possible as we cannot guarantee all features and pages will work in Internet Explorer 6 or below.
  • We do not support Netscape Navigator, Opera or WebTV.
  • Our site should also perform well on browsers utilizing the Gecko or Webkit rendering engines, though we may not be able to support problems with them.
  • We recommend that you have JavaScript and cookies activated in order to access all features.
  • In addition, certain multimedia and interactive features require Adobe Flash Player. Click here to get the free download.

Reviewed 2011-03-11.